Fragen über die Videos ab 5.1

Videos von HomepageHelfer und Diskussionen dazu.

Moderatoren: goefi-chiangmai, Jasko

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3130
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 18:10

Das Problem scheint wircklich in der PHP Version zu liegen. Ich habe das damals auf der Version 5.1 programiert, und nocheinmal in der Version 5.6 in beiden geht es ohne Probleme. Aber jetzt habe ich es in der Version 5.4 getestet und es klappt nicht, ich bekomme einen Fehler Angezeigt. Ich teste das ganze noch einmal auf einem anderen Server mit genau der Version die du hast, mal schauen was raus kommt.



Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 18:50

Alles klar. Danke, dass du mir da so hilfst.

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3130
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 18:51

OK, ich habs jetzt auch auf der 5.4 Version zum laufen gebracht. War ein ganz dummer Fehler, die Endungen der Fonts waren .TTF und im Code wurden die als .ttf angegeben. Das heißt der Code ist Case sensitive und man muss darauf aufpassen. Das könnte vieleicht auch der Fehler bei dir sein.
MFG

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 19:31

Leider kann es das nicht sein, denn bei mir haben die Schrifttypen, also die Dateien davon, tatsächlich die Endung .ttf.

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3130
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 19:49

Ok, dann versuch mal diese Linie auszukommentieren.

header("Content-Type: image/jpeg");

und dann die Datei zu laden und schau mal ob du irgend welche Fehler oder Warnungen bekommst die gut lesbar sind. Ist es nur ein Symbolgewusel kann diese Masnahme dir nicht helfen, aber hast du was lesbares kannst du vieleicht das Problem finden das die Schrifft nicht angezeigt wird.

Eine zweite möglichkeit wäre eine Standardschrifft zu nutzen und zwar nur diese um zu schauen ob die anderen einen Fehler oder so haben und deswegen nicht angezeigt werden. Aber erst mal das eine und dann schauen wir weiter.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 21:22

Okay... also, wenn ich die Zeile auskommentiere, dann erscheint bei mir kein Hintergrundbild mehr, sondern nur noch ein Gewusel von Zahlen und Buchstaben in den unterschiedlichen Schrifttypen, die wir ausgewählt haben. Dann versuche ich jetzt mal die zweite Variante.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 21:45

So, jetzt habe ich auch die zweite Variante mit Standardschriften von meinem Computer versucht. Habe auch die richtig klassischen genommen. Also Arial, Calibri und Times New Roman. Das hat nicht funktioniert. Hast du vielleicht noch eine Idee woran es liegen könnte? Das blöde ist, dass du meine Dateien ja nicht direkt sehen kannst, dann fällt es sicher schwerer eine Lösung zu finden.

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3130
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 21:48

genau das ist es, aber da du die Standard Schrifften genommen hast, kannst mir jetzt deinen Code posten, ich übernehme ihn und versuche mal den Fehler zu reproduzieren. Wenn er reproduzierbar ist kann man was machen, ist er nicht reproduzierbar wird es schwer, weil es dann System abhängig sein muss.

Benutzeravatar
Schäfchen_93
Foren Anfänger
Foren Anfänger
Beiträge: 24
Registriert: Do 28. Jan 2016, 22:06
Mein Vorname: Kristin

Re: Fragen über die Videos ab 5.1

Beitragvon Schäfchen_93 » Fr 29. Jan 2016, 22:02

Okay. Ist aber eigentlich genau der selbe, wie deiner. Hab ihn ja komplett übernommen, da ich zunächst glaubte, dass ich in meinem anderen Code einen Fehler gemacht habe. Wahrscheinlich kann man den Code auch professioneller posten, als ich es jetzt mache. Aber naja wurstig.
Hier folgt der Code:

Code: Alles auswählen

<?php
//starten der session
session_start();

//alten capcha aus session loeschne
unset($_SESSION['captcha_code']);

//Grafik chache verhindern
header( "Expires: Mon, 26 Jul 1997 05:00:00 GMT" );
header( "Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT" );
header( "Cache-Control: no-store, no-cache, must-revalidate" );
header( "Cache-Control: post-check=0, pre-check=0", false );
header( "Pragma: no-cache" );

//diese Datei erzeugt ein jpeg
header('Content-type: image/jpeg');

//Code generieren
$SymbolMenge = "2345689ABCDEFGH";
$ZufallString1 = substr(str_shuffle($SymbolMenge),0,2);
$ZufallString2 = substr(str_shuffle($SymbolMenge),0,2);
$ZufallString3 = substr(str_shuffle($SymbolMenge),0,2);

$KomplettString = $ZufallString1 . $ZufallString2 . $ZufallString3;

//Sicherheitscode
$_SESSION['captcha_code'] = md5($KomplettString);

//grafik erzeugen
$Schriftarten = array("arial.ttf","times.ttf","calibri.ttf");
$Bilddatei = imagecreatefrompng('hintergrund.png');

$blau = imagecolorallocate($Bilddatei, 0,19,127);
$rot = imagecolorallocate($Bilddatei, 255,0,0);
$pink = imagecolorallocate($Bilddatei, 255,0,220);

imagettftext($Bilddatei, 12, 15, 3, 24, $blau, $Schriftarten[0], $ZufallString1);
imagettftext($Bilddatei, 16, 0, 26, 15, $rot, $Schriftarten[2], $ZufallString2);
imagettftext($Bilddatei, 14, -20, 53, 18, $pink, $Schriftarten[1], $ZufallString3);

imagejpeg($Bilddatei);

//speicher freigeben
imagedestroy($Bilddatei);
?>
Zuletzt geändert von Jasko am Fr 29. Jan 2016, 22:17, insgesamt 1-mal geändert.
Grund: Code gekenzeichnet

Benutzeravatar
Jasko
Globaler Moderator
Globaler Moderator
Beiträge: 3130
Registriert: Di 21. Feb 2012, 06:59
Mein Vorname: Herr Jasmin ;)
Wohnort: Frankfurt am Main
Kontaktdaten:

Re: Fragen über die Videos ab 5.1

Beitragvon Jasko » Fr 29. Jan 2016, 22:15

Ja der Code funktioniert bei mir auf dem Server mit der php Version 5.4

OK. Jetzt gehn wir mal nach und nach allesw durch.

1. Ist dein Bild im png format gespeicher

2. Bekommst du einen Fehler angezeigt wenn du das hier auskomentierst

Code: Alles auswählen

$Bilddatei = imagecreatefrompng('hintergrund.png');


3. Mach dein Hintergrundbild nur weiß, und ersetze diesen Code,

Code: Alles auswählen

imagettftext($Bilddatei, 12, 15, 3, 24, $blau, $Schriftarten[0], $ZufallString1);
imagettftext($Bilddatei, 16, 0, 26, 15, $rot, $Schriftarten[2], $ZufallString2);
imagettftext($Bilddatei, 14, -20, 53, 18, $pink, $Schriftarten[1], $ZufallString3);


mit diesem Code

Code: Alles auswählen

imagettftext($Bilddatei, 12, 0, 3, 24, $blau, $Schriftarten[0], $ZufallString1);
imagettftext($Bilddatei, 12, 0, 26, 24, $blau, $Schriftarten[0], $ZufallString2);
imagettftext($Bilddatei, 12, 0, 53, 24, $blau, $Schriftarten[0], $ZufallString3);


dann schauen wir mal was passiert...


Zurück zu „PHP Schule“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast